F34 Gnome 40 test day

More information about the event can be found here: http://fedoraproject.org/wiki/Test_Day:2021-03-17_Fedora_34_Gnome_40.0
Go back to List of Events.

Results

Clicking on the testcase name will show you the appropriate "how to test" page.
Click on the Enter result button, to enter result.
Note: results are cached and realoaded from the database each 10 seconds.

Basic

Username Profile Gnome Accessibility Gnome Classic mode Gnome Initial Setup Gnome Lock Screen Gnome Login Screen Gnome Maps Gnome Music Gnome Web Gnome Terminal Desktop update notification Comments
Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result
Hoboprimate [1] 1. #1940239, Videos from peertube instances play without sound. Youtube works fine.
Renault fr_FR
adamthiede [1] 1. Some media doesn't play in the browser. Fixed by adding rpmfusion. Certainly codec-related. Otherwise web works just fine.
akumar99 VMware VM [1] 1. Doesn't work with root user. Says GNOME Music could not connect to Tracker.
alciregi Lenovo ThinkCentre M73z, 4GB RAM
alre VMware; Fedora 34 (Workstation Edition Prerelease) aka Test Day ISO with Gnome Version: 40.beta.0
asciiwolf GNOME Boxes Virtual Machine with Test Day x86_64 image with GNOME 40 RC [1] [2] [3] [4] [5] [6] [7] 1. Typing Assist did not work or I am doing something wrong (I don't have any experience with typing assist). After toggling the "Enable by keyboard" switch, starting Text Editor and holding down the Shi ft key for 8 seconds, nothing happened.
2. On screen keyboard and screen reader were not enabled after login when enabling them in GDM. After enabling them both in Settings for my user account, on screen keyboard worked fine, but screen reader did not work at all. I later found out that this was caused by my (GNOME Boxes emulated) sound card not being detected in the actual user session. In GDM, the sound was working, but was distorted and lagging and on screen keyboard was working fine.
3. Works fine except that files and directories on desktop are not displayed for some reason.
4. GNOME Help is not displayed after Initial Setup finishes, but this is expected (it is not being displayed anymore since GNOME 40).
5. Worked fine except a minor issue: https://gitlab.gnome.org/GNOME/gdm/-/issues/687
6. There was no "Use the system width font" option, however I have tried changing the font being used to Monospace. Everything worked fine.
7. No update notifications were displayed although there were actually some updates available for installation when manually opening Software and switching to the "Updates" tab. However, after their inst allation, I got a notification that updates were installed, so maybe there was something wrong and it got fixed by the update.
bhavin192 ThinkPad E470 updated 19th March [1] [2] 1. #1939903, The on-screen keyboard fails to show up, and this causes the restore from tray to not work, it just does nothing when we click on any item from the tray.
2. #1941033, Does not allow to login into the new users and keeps failing with error related to fingerprint authentication. The new users don't have fingerprint authentication enabled.
bsanford qemu-kvm-5.1.0-9 gnome-boxes-3.38.2-2 using Fedora-Workstation-Live-x86_64-34-20210316.n.103 [1] 1. #1940124, After switching admin account to non admin and user account to admin a reboot of system results in another setup without installed users.
condor HP 8470p laptop with an Intel i5-3320m CPU 60gb eternal hard drive
condor HP 8470p laptop with an Intel i5-3320m CPU 60gb eternal hard drive with Fedora-Workstation-Live-x86_64-34-20210316.n.103.iso [1] 1. #1939903, On screen keyboad fails to display when using Gnome Classic
condor HP 8470p laptop with an Intel i5-3320m CPU 60gb internal hard drive with Fedora-Workstation-Live-x86_64-34-20210316.n.103.iso
condor HP 8470p laptop with an Intel i5-3320m CPU 60gb internal hard drive with Fedora-Workstation-Live-x86_64-34-20210316.n.103.iso
copperi 5.11.6-300.fc34.x86_64 F34 32Gb Ryzen 7 3700x NVIDIA GP106GL [Quadro P2200] X11
danniel lenovo ideapad S145 I7 8GB
evillagr KVM, x86_64, Test Day IOS with Gnome 40 rc [1] [2] 1. Screen reader voice sound to metallic
2. on-screen keyboard does not display well, key borders are visible at the bottom. Restore minimized windows from taskbar does not work with on-screen keyboard active.
fredm Virtual Machine: Test Day IOS with Gnome 40 rc [1] [2] [3] [4] [5] 1. Worked fine but screen reader voice was very static sounding.
2. on screen keyboard not opening/visible. It seems like it wants to open because windows move when it should be shown, to make room for it.
3. After changing from defaults the screen goes blank. No lock screen shown. When attempting to get lock screen back by clicking mouse or tapping keyboard the screen immediately goes back into desktop.
4. Music in ~/Music or ~/Downloads is not found.
5. Everything is fine but there is no gear icon as mentioned in the test.
geraldosimiao KVM - Qemu-systemx86_64 with 20210316.iso and updated gnome 40 [1] [2] [3] [4] [5] 1. Screen reader not working properly, sounds distorted and scratchy, and sometimes don't start at all.
2. #1939739, Before today's mega update, it showed the refered langpack bug, but now after the update not anymore. On the first install all worked fine, but testcase didn't: (gnome-shell:11497): mutter-WARNING ** : 10:47:03.443: Failed to create backend: Could not take control: GDBus.Error:System.Error.EBUSY: Device or resource busy
3. ISO came with Rythmbox, it played the musics fine, but don't insert music data automatically when music is saved on the "music" folder (as sugested on the test case)
4. So its been a wile since Fedora Workstation come with Firefox. Firefos is running fine on this ISO, no regressions found.
5. Notifications didn't show, even before todays updates.
giuj qemu-kvm, gnome boxes3.38.2-stable x86_64 [1] [2] 1. On screen keyboard won't show up
2. Everything is working properly, but i had to restart epiphany more than once in order to have it loading websites properly. Audio sometimes won't work
hoboprimate [1] [2] [3] [4] 1. #1940144, In the on-screen keyboard, opening the submenu of a character (e.g. the period (.) character) and clicking on sub-character, doesn't type it
2. #1940144, In the on-screen keyboard, opening the submenu of a character (e.g. the period (.) character) and clicking on sub-character, doesn't type it
3. #1940178, Sometimes, unlocking the screen crashed the desktop back to gdm, running in wayland
4. #1940239, PeerTube videos play without sound. (Sorry for repost under different profile name)
jpbn early iMacpro 2008 uefi [1] [2] [3] 1. had to install gnome-music , is not included in GNOME?
2. In SETUP Install Package-x-generic-16.pngepiphany package. : link https://apps.fedoraproject.org/packages/epiphany is empty Configure Gnome Web in "Super menu" - "Personal Data". (I do n ot know what you mean by Super Menu in Gnome-web or elsewhere) No gearwheel in Web..
3. On the General tab, uncheck "Use the system width font" and try changing the font. NO mention of Use system wide font there. On the Background tab choose "Transparent Background". On the Colors tab uncheck "Use colors from system scheme" and select one of the built-in themes. Both options are in 1 tab, colors and backgroun tab. Your test descriptions are very bad. Please edit your test descriptions. I spend time to test your job, and it seems you do not care about testing.
jpbn early iMacpro uefi [1] [2] [3] 1. in Terminal :$ gnome-shell --mode=initial-setup --replace results in : (gnome-shell:4397): mutter-WARNING **: 07:24:11.793: Failed to create backend: Could not take control: GDBus.Error:System.Er ror.EBUSY: Device or resource busy
2. keyboard on screen (accesibility) hides button for choice for other user Left below screen. the litlle puppets.
3. On how to test > results: "There should be whispering" === What do you mean by whispering? Hear no sound when handling Maps.
laolux [1] [2] 1. GNOME Maps does not respect my system wide proxy settings and thus fails to connect to the internet. Proxy settings are set in Gnome Settings and are confirmed to work via bash and Firefox.
2. Automatically sets http_proxy and http_proxy environment variables according to settings in Gnome settings :-)
laolux baremetal liveiso [1] 1. On-Screen keyboard does not open, rest seems to work. Magnification works.
lruzicka bare-metal - Dell Precision Tower 7810, Gnome 40 rc [1] [2] 1. #1939903, On screen keyboard does not work.
2. I tested Rhythmbox instead, as this is the default music playing application in Gnome. Works.
luya Fedora 34 Design Suite Prerelease on HP Envy X360 Convertible 15 Ryzen 2500U [1] [2] [3] 1. Screen reader is too sometime too quick. It will be nice to have a clear tone and pitch and the ability to switch to either male and female voice. For users having a pen i.e. Stylus, it will be great to expand that Assisting functionality.
2. GNOME Help uses outdated touchscreen hand gesture for the new GNOME Shell 40
3. Some instructions are outdated i.e. missing "System Width fonts"
merkaba
merkaba ThinkPad T440p, test day image [1] [2] [3] [4] 1. Screen reader is hard to make out. Pipewire crashed when disabling screen reader. Unable to toggle sticky keys with shift key.
2. If I swipe in the incorrect direction on the Lock Screen, two blank boxes appear in the bottom right corner of the screen.
3. Hint boxes (e.g. "Add to new route" etc) are incorrectly shown on the side of the map and not below the button being overed on.
4. I had to log out after installing before Music would find all my tracks in ~/Music.
modehnal KVM x86_64 Test Day ISO with GNOME 40 rc [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] 1. Screen reader with metallic voice, not understandable. Zoom is not smooth and jumps around after a while. No notification after slow keys were turned on.
2. Screen reader appeared bellow screen frame, barely visible. All other tests were fine.
3. Screen Keyboard did not appear when needed. All other tests worked fine.
4. First init setup worked, but the command gives mutter-WARNING: Failed to create backend: Could not take control: GDBus.Error:System.Error.EBUSY: Device or resource busy
5. When locking I see time/date but screen will go black after a second or so.
6. There is no keyboard layout switcher available on login screen, while having defined multiple. Test seems outdated. Other features seem fine.
7. Maps is not smooth when moving, stutters heavily while zooming and moving around. Otherwise seems fine.
8. There is no gearwheel icon.
9. Terminal works fine, the test page is very outdated.
10. The notification did not show, but pkmon did show transaction and percantage of some action
mstfcn21 Asus motherboard, 4 GB Ram, Amd Radeon 6570 [1] [2] 1. Successful, solid
2. I locked it for the first time and came up with a black screen, I did not fully read the error, forced off the computer and turned it on again. Birdahakine was not like that
mstfcn21 mstfcn21 [1] 1. Successful, solid
nickavem AMD® Ryzen 5 2600x six-core processor × 12 , AMD® Radeon rx 5600 xt, 15.6 GiB RAM, 1.0 TB Disk Capacity [1] [2] 1. #1940180, ``` [andythurman@rockhopper ~]$ gnome-shell --mode=initial-setup --replace (gnome-shell:4343): mutter-WARNING **: 14:13:28.621: Failed to create backend: Could not take control: GDBus.Error:System .Error.EBUSY: Device or resource busy ```
2. Highly outdated test page, however seems to work fine.
nielsenb HP Compaq 8510w Intel T9300 AMD RV630 [1] 1. Strange resize behavior: https://gitlab.gnome.org/GNOME/gnome-terminal/-/issues/129
petrvelicka Fedora Workstation 34 @ Dell Latitude E6540 [1] [2] [3] 1. 1. Screen reader doesn't work in Firefox 2. No notification on enabling the soft keys
2. The search whispering is quite weird, searching for "restaurant" yields some restaurant in Pyongyang, DPRK (I'm physically in Europe). No one of the results are in my country at all (if the word resta urant is written in the local language, then the app correctly shows the facilities near me).
3. 1. 4k video on Youtube failed to play (it works perfectly on Firefox), sometimes video resets the playback time to 0 when changing the quality, at other times it changes the quality but loses the soun d. 2. maybe not a bug, but I was unable to zoom the page in by using ctrl+mouse wheel (ctrl++ and ctrl+- works as expected)
rantadi [1] 1. Nearly everything works fine and smooth. But cant get Access to some Financial Sites in Germany, like https://www.comdirect.de or https://www.commerzbank.de or https://www.guidants.com - This should b e a User Agent thing.
slembcke [1] [2] 1. Screen magnifier w/ "Magnifier extends outside of screen" doesn't clear buffer. The unmagnified screen is visible but flickers heavily. Not a breaking problem, but it's very unpleasant.
2. There are heavy compositor glitches on my second monitor when switching workspaces. This does not occur in the regular version. I ran the live-cd on bare metal. Icons do not appear on the desktop.
slembcke Ryzen 3700X w/ Radeon RX 5700 [1] [2] [3] [4] 1. Login screen always uses QWERTY layout, even when the user has a different default or multiple layouts. There is no layout switcher available. This differs from the lock screen which uses the last sel ected layout and provides a layout switching menu in the usual place.
2. Maps performance stutters consistently when zooming, but otherwise seems to work great.
3. Was not present on the live cd, though RhythmBox was in the dock. After installing it with dnf, it imported and played music as expected. There were a few songs I tried searching for that would never come up in results. Unclear why.
4. An odd but minor bug: If I enable transparent background and click the hamburger menu, its drop shadow is an opaque white square.
sp6ina Huawei Matebook 14 2020 AMD [1] 1. very slow
theonlyandy [1] [2] [3] [4] 1. Everything worked fine
2. #1940202,
3. Fedora 34 (Workstation Edition Prerelease), Gnome 40.beta.0 1: Screen turns black, cannot see time 2: Tapping or sliding the black screen wont unlock it; 5: screen does not lock after configured time
4. #1940195, #1940199, 2: No system wide keyboard layouts can be configured from settings. Touch keyboard on login screen does not accept special characters. When resuming, lock screen does not show, but screen is black.
u9000 Virtual Machine: Test Day .iso w/ GNOME 40.rc (3.5 GB RAM) [1] [2] [3] [4] [5] 1. 1. Screen Reader sounded like errape but at a normal volume. 2. In gnome-terminal, Sticky Keys entered "^[<key>" for every key press, & entirely stopped backspace from working. 3. I didn't test Mous e Keys, but everything else worked fine.
2. Everything worked well, although I didn't hear any whispering when zooming in and out as the expected results suggested; I'm not sure if that was a typo or something.
3. I haven't tested this yet; I've marked it info because I accidentially submitted my test for GNOME Maps here.
4. Everything worked well, although I didn't hear any whispering when zooming in and out as the expected results suggested; I'm not sure if that was a typo or something.
5. See my comment regarding GNOME Accessibility
zlopez Virtual Machine: Test Day ISO with Gnome 40 RC [1] [2] [3] [4] [5] 1. Screen reader sounds distorted, screen keyboard didn't show up till I pressed a key on hardware keyboard, step 3 didn't do anything
2. #1940580, Step 5 didn't work, see bug
3. Stesps 1,2,3 of testcase are already done during installation. Steps containing "About You" and "Password" screen are missing in testcase. Initial setup itself worked without issue, the settings were persistent between reboots.
4. I couldn't finish step 8 (I don't see any option like this in hamburger menu)
5. Step 1: is outdated (Activities doesn't have any applications in them anymore), Step 2: is now Preferences->Profiles, Step 3: option "Use the system width font" doesn't exist, Step 4: transparent back ground is now in Colors tab of profile
zn30 F34 VM in Gnome Boxes [1] [2] 1. 'Window List' extension was not enabled by default. Is it expected or not?
2. Failed to recognize ogg files. Rhythmbox worked fine.

Gnome Shell

Username Profile Activities Extensions Dash Extensions gnome org Extensions install Extensions remove Extensions tweak tool Overview Search Workspaces Comments
Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result
Renault fr_FR [1] 1. Activate some extensions does not work from the website, but works fine with the desktop app
adamthiede Thinkpad X220 [1] [2] 1. Works with Firefox with extension, not with Epiphany
2. Extensions can be managed through extensions app. I observed the "Extensions" sidebar item in the gnome-tweaks app is completely gone. The tweaks app alerts the user that extensions are now in the ext ensions app upon its first launch.
asciiwolf GNOME Boxes Virtual Machine with Test Day x86_64 image with GNOME 40 RC [1] [2] [3] 1. Extension installed using dnf was still displayed in the Installed section of extensions.gnome.org after being uninstalled using dnf. It was gone after the session restart.
2. Extension management is no longer a part of the gnome-tweak-tool. It was moved to a separate application that does not seem to allow installation of local extensions.
3. GNOME Software search provider is broken and causes Software to hang. Firefox search provider also has some issues. See my result in "Exploratory Testing" section for more details.
bhavin192 ThinkPad E470 updated 19th March [1] [2] [3] 1. Works with Firefox but Epiphany says "We cannot detect a running copy of GNOME on this system".
2. Did not find any working extensions with dnf search gnome-shell-extension. Installing gnome-shell-extension-gpaste, does not show up on extensions.gnome.org.
3. Tweaks no longer manage extensions.
copperi 5.11.6-300.fc34.x86_64 F34 32Gb Ryzen 7 3700x NVIDIA GP106GL [Quadro P2200] X11
danniel
evillagr KVM, x86_64, Test Day IOS with Gnome 40 rc
fredm Virtual Machine: Test Day IOS with Gnome 40 rc [1] [2] [3] [4] [5] [6] 1. Cannot install gnome shell extensions from extensions.gnome.org. Showing as incompatible.
2. works fine
3. worked find
4. cannot install gnome tweak tool via yum as specified in the test. Error: Error downloading packages: Curl error (7): Couldn't connect to server for https://mirrors.fedoraproject.org/metalink?repo=u pdates-testing-f34&arch=x86_64 []
5. worked fine.
6. worked fine.
geraldosimiao KVM - Qemu-systemx86_64 with 20210316.iso and updated gnome 40
giuj qemu-kvm, gnome boxes3.38.2-stable x86_64
jpbn early iMacpro 2008 uefi [1] 1. the test page is for the wrong gnome version. please rewrite.
lruzicka bare-metal - Dell Precision Tower 7810, Gnome 40 rc
modehnal KVM x86_64 Test Day ISO with GNOME 40 rc [1] [2] [3] [4] [5] 1. Extensions installed from website can control GNOME, but already installed have no effect when switching. They however change/display correctly when changed via tweaks.
2. Outdated test page
3. Outdated test page.
4. Outdated test page.
5. Outdated test page.
nickavem AMD® Ryzen 5 2600x six-core processor × 12 , AMD® Radeon rx 5600 xt, 15.6 GiB RAM, 1.0 TB Disk Capacity [1] 1. Highly outdated, but seems to work fine
nielsenb HP Compaq 8510w Intel T9300 AMD RV630
rantadi
slembcke Ryzen 3700X w/ Radeon RX 5700 [1] [2] 1. When you have two workspaces and you close the last window on the first from the activities screen, it makes the workspace switcher disappear while leaving you on the now empty workspace. This is real ly awkward. It should either leave the workspace switcher until you navigate to the last workspace or simply switch you to it.
2. Hiding the switcher when there is only one workspace is very awkward for a few reasons. It's the usual widget I use from Activities to manage workspaces and it doesn't show up until you create a works pace by dragging a window to the tiny strip for the next workspace. This strip is *extra* tiny when there is only one workspace, and it only allows me to create a new workspace to the right (unlike the widget). Lastly, that tiny strip is on the edge between my two monitors and is very easy to miss. Otherwise it looks and performs smoothly even on multiple monitors with mismatched sizes and refresh rates.
zlopez Virtual Machine: Test Day ISO with Gnome 40 RC [1] [2] [3] [4] [5] 1. #1940887, Step 1: I installed TopIconsPlus, but they weren't visible in Extensions app till I restarted the VM (couldn't be enabled after the restart)
2. Step 1: yum should be replaced by dnf, gpk-application couldn't be found, Applications->System tools->Add/Remove Software doesn't exist in GNOME 40; Same for step 2
3. Step 1: gpk-application couldn't be found (Applications->System tools->Add/Remove Software doesn't exists in Fedora anymore); Step 3: Accessories->Advanced Settings doesn't exist in GNOME 40, GNOME Ex tensions should be used instead of gnome-tweak-tools for extensions management
4. gnome-tweak-tools doesn't manage extensions anymore
5. Step 2: The overview is now on top of the screen in GNOME 40

Gnome Online Accounts

Username Profile Add Facebook Add Google Add IMAP and SMTP Add Kerberos Add MS Exchange Add Windows Live Add ownCloud Comments
Enter result Enter result Enter result Enter result Enter result Enter result Enter result
asciiwolf GNOME Boxes Virtual Machine with Test Day x86_64 image with GNOME 40 RC
danniel lenovo ideapad S145 I7 8GB
evillagr KVM, x86_64, Test Day IOS with Gnome 40 rc [1] 1. gnome crash after account config, but setup work
fredm Virtual Machine: Test Day IOS with Gnome 40 rc
lruzicka bare-metal - Dell Precision Tower 7810, Gnome 40 rc
modehnal KVM x86_64 Test Day ISO with GNOME 40 rc [1] 1. Error: App Not Setup: This app is still in development mode, and you don't have access to it. Switch to a registered test user or ask an app admin for permissions
nickavem AMD® Ryzen 5 2600x six-core processor × 12 , AMD® Radeon rx 5600 xt, 15.6 GiB RAM, 1.0 TB Disk Capacity [1] 1. #1940186,
zlopez Virtual Machine: Test Day ISO with Gnome 40 RC [1] [2] 1. Tested with FEDORAPROJECT.ORG domain and klist is listing the ticket correctly
2. I don't see ownCloud entry in Online Accounts, so I assume this means NextCloud. I tried to add my Nextcloud server and the integration works fine.

Disk Management

Username Profile Basic LVM Modify Multipath Remote Comments
Enter result Enter result Enter result Enter result Enter result
Renault fr_FR
adamthiede Thinkpad X220 [1] 1. Samsung EVO 840 pro 120GB shows up with "Samsungx20SSDx20840x20PROx20Seriesx20x20x20x20x20x20x20x20x20x20x20x20x20x20 (DXM05B0Q)" in "Model" field. Other than that, works fine.
alre VMware; Fedora 34 (Workstation Edition Prerelease) aka Test Day ISO with Gnome Version: 40.beta.0
asciiwolf GNOME Boxes Virtual Machine with Test Day x86_64 image with GNOME 40 RC
bhavin192 ThinkPad E470 updated 19th March
fredm Virtual Machine: Test Day IOS with Gnome 40 rc
geraldosimiao KVM - Qemu-systemx86_64 with 20210316.iso and updated gnome 40
giuj qemu-kvm, gnome boxes3.38.2-stable x86_64
laolux baremetal liveiso
lruzicka bare-metal - Dell Precision Tower 7810, Gnome 40 rc
modehnal KVM x86_64 Test Day ISO with GNOME 40 rc
nickavem AMD® Ryzen 5 2600x six-core processor × 12 , AMD® Radeon rx 5600 xt, 15.6 GiB RAM, 1.0 TB Disk Capacity [1] 1. Could not so unsafe tests as my only LVM group is root
slembcke Ryzen 3700X w/ Radeon RX 5700

Exploratory Testing

Username Profile Exploratory Testing Comments
Enter result
aday [1] [2] [3] 1. #1939999,
2. #1939984, #1939974,
3. #1939974, After boot the live session opens in the overview, then quickly switches to the desktop. It's disorientating.
asciiwolf GNOME Boxes Virtual Machine with Test Day x86_64 image with GNOME 40 RC [1] [2] [3] 1. #1940929, GNOME session randomly crashed.
2. #1940190, #1940612, #1940608,
3. https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1178 https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1179 https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1180 GNOME Software issues. One of them is a major one that causes Software to hang and user must restart their session to resolve this. Upstream fixes for all of them are already available.
bsanford@redhat.com [1] 1. #1940124,
nickavem AMD® Ryzen 5 2600x six-core processor × 12 , AMD® Radeon rx 5600 xt, 15.6 GiB RAM, 1.0 TB Disk Capacity [1] 1. #1939974,
pablodav model name : AMD FX(tm)-8150 Eight-Core Processor - Manufacturer: MSI Product Name: MS-7640 - GPU id = 0 (AMD RADV POLARIS12 (ACO)) [1] 1. #1940266, I did an exploratory tests Everything looks to be working fine in desktop, even with lot of different applications and steam too. Multi-monitor ok. Unique thing found is about automatic updates in gnome-software for flatpak apps, looks like those are not automatically updating. If I manually click update, it works.
Wiki Metadata