F37 Gnome 43 Beta test day

More information about the event can be found here: http://fedoraproject.org/wiki/Test_Day:2022-08-15_Fedora_37_GNOME_43_Beta
Go back to List of Events.

Results

Clicking on the testcase name will show you the appropriate "how to test" page.
Click on the Enter result button, to enter result.
Note: results are cached and realoaded from the database each 10 seconds.

Basic

Username Profile Gnome Accessibility Gnome Classic mode Gnome Initial Setup Gnome Lock Screen Gnome Login Screen Gnome Music Gnome Web Desktop update notification Gnome Files Gnome Software Evince File Display Comments
Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result
Geoffrey Gordon Ashbrook [1] [2] [3] [4] [5] [6] [7] [8] 1. 1. screen keyboard was very very delayed (I thought it didn't work at all) but then the toggle button froze-glitched and will not be toggled. bug; 2: maybe relating to the screen keyboard issue: the d ash will NOT come up at all now, either with 3-fingers up on the track pad or a mouse in the upper left of the screen...very bad. very broken.
2. I have no idea what the instructions page is saying to do. No goal, no steps...what are you asking for? https://fedoraproject.org/wiki/QA:Testcase_Gnome_Classic_mode You say to installl...what how? Is it there, it isn't there? It isn't there but I should test it? What are you talking about?
3. You should see actual time and date: yes Screen should unlock: NO: any mouse or key simply goes back to the normal session with a glitchy blink Screen should stay locked and show err or message: NO, neither "Log in as another user" option does not exist Screen should turn off and lock after configured time. ...what? Notifications should be visible on locked screen: no data on this
4. no does not work, does not lock, does not show locked, does not show ID
5. using ISO live, was able to make multiple users, could not use iillegal characters, could not log in with another user
6. What do you mean by "Gnome Music"? Rhythm-box? There are two 'music' apps in the software installer. What are you asking me to test? Anyting? Speakers? Rhythm box works...so far.
7. using a live iso, so instructions unclear: in software app: updates tab would not open at all, seemed odd
8. I opened a pdf with the default software IF that is what you meant. What is Evince? Please be clear about what you are talking about and get the names of your applicates straight. e.g. I can't even use the default gnome editor from command line because there's no way to find out all the disparate names the get used and printed.
Geoffrey Gordon Ashbrook dell inspiron laptop live iso [1] 1. somewhat works but update tab does nothing, has software, tried downloading and running endless sky but got error: unable to initialize GLEW! tried installing Enigma, that worked after seeming to free ze during download.
aeitcpopce QEMU VM, Intel i5-9300H (8) @ 2.400GHz 8GB RAM [1] [2] [3] [4] 1. Worked well. It would be nice if the accessibility menu didn't close after every toggle, and also if it provided some shortcut to the accessibility settings pane.
2. Music audio did not reliably play. Keyboard shortcuts not working. No debug option.
3. All steps worked well
4. Received the notification, successfully installed update.
andilinux GNOME BOXES [1] 1. Unable to install "GNOME Tweaks" as not supported
andilinux GNOME BOXES - F37
bittin Virtualbox [1] [2] [3] [4] 1. Writing assist failed
2. tracker-miners/tracker does not seem to work making gnome-music not seeing any music in the home music folder
3. Google Chrome did not work to install
4. gnome-software is fixed in todays compose 20220816
bittin Virtualbox
bmilar Dell Precision 3551 [1] [2] [3] 1. 1. Zoom scrolls at cca 1 fps when Enable Animations is off. 2. Sticky keys does not announce pressed (active) modifiers.
2. Nautilus doesn't show icons on desktop.
3. I haven't found the "Connect to Server" function.
couchfox Dell Inspiron 7577 (bare metal) [1] [2] [3] [4] [5] 1. Large Text, Cursor Size, Zoom, Screen Keyboard, Click Assist all work as expected. Did not experience Screen Keyboard lag reported elsewhere.
2. 5. No icons displayed on Desktop. Not sure if this is a bug or if test case is dated?
3. Tested both RPM and Flatpak, works as expected for local files. As noted elsewhere the `-d` for debug does not work. I could not follow the instructions regarding remote files... if Music supports UPn P sources I can't see how :)
4. Preferences -> "Navigate folders in a tree" does not exist. Suspect the test case is out of date, as Files 42.0 on F36 is the same; no regression.
5. Cannot install anything via RPM; Flatpaks install okay but Software crashes immediately after the flatpak install each time.
domcox bare metal [1] [2] [3] [4] [5] [6] 1. Click and move the mouse pointer using the keypad: If I log out then log in again, the option is still activated, but using the Num keyboard for moving the mouse doesn't work anymore.
2. Pressing the ?123 key in the virtual keyboard activates the num keys at the top of the keyboard, but if I press one of these keys, for example '2', I randomly get '2' or '~', the underlying character.
3. Nautilus doesn't show incons on the Desktop, not sure if this is an issue.
4. Either way I lock the screen, I see the lock screen half a second, then the screen goes black, I have to hit the keyboard to see actual time and date again.
5. Navigating to "Super menu" - "Preferences" doesn't show "Display" nor "Navigate folders in a tree" in "List View".
6. Checking properties on files displayed in the "recent" place, bring the message: Unknown Permissions The permissions of the selected files could not be determined.
ernmander
ernmander Bare Metal [1] 1. Slow to load
freddyw VIrtualBox [1] 1. as mentioned by others, installing rpm's does not work, flatpaks are fine. OS updates not working either, seeing "Failed to get cache filename" in the journal and "PKI file /etc/pki/rpm-gpg/RPM-GPG-KE Y-fedora-39-primary is not a public key".
frosetrain GNOME Boxes [1] [2] [3] 1. I then forcefully shut down the virtual machine and started it again, but when the system was booting, it got stuck on the loading screen with the Fedora logo. The last systemd boot message displayed was "Mounted sysroot.mount".
2. This test was not performed because the **only user** on the system did not have administrator privileges, and so could not create new user accounts. I then attempted to restart the system, but becaus e the only user did not have admin, I was only able to log out. Upon logging back in, I realised that all my apps, both in the Dock and in the app menu, were gone. Even trying to launch Settings from the top-right corner menu did not work.
3. RPMs are not supported
frosetrain frosetrain [1] [2] 1. No notification appeared to inform me that slow keys were turned on
2. The screen reader continued speaking after being turned off
geraldosimiao x86_64 KVM virt-manager UEFI [1] [2] [3] [4] 1. Live-x86_64-37-20220815.n.0.iso
2. Live-x86_64-37-20220815.n.0.iso
3. Firefox is doing fine
4. At Live-x86_64-37-20220815.n.0.iso, even with google repo enabled, didn't get to install chrome from gnome-software, get the "chrome doesn't have support" message.
heliosstyx
heliosstyx heliosstyx [1] 1. no rpm software installation possible
hricky Intel® Core™ i7-4790 CPU, 32 GB RAM, Bare Metal [1] 1. There seems to be no debug option (gnome-music -d) as described in How to test. Music files in ~/Downloads are not displayed. In Playlists tab "Never Played" shows recently played, but "Recently Pla yed" is empty.
hricky Intel® Core™ i7-4790 CPU, 32 GB RAM, Bare Metal, Fedora Linux 37.20220820.n.0 (Silverblue Prerelease) [1] [2] [3] 1. Alt-Tab shows windows and applications.
2. Keyboard menu doesn't show even with multiple system-wide keyboard layouts configured.
3. Navigating to "Super menu" - "Preferences" doesn't show "Display" nor "Navigate folders in a tree" in "List View".
jakfrost QEMU/KVM - Virt-Manager [1] [2] [3] 1. Always show accessibility menu should be on by default, it currently isn't with this during installation or after first install during setup. From an accessibility POV that's a blocker.
2. Was a fast and smooth process.
3. As the system is apparently up to date, I forced a manual update check and it came back up to date.
mairacanal F37 Workstation on Intel i5-4460 CPU with Radeon RX5700 XT [1] [2] [3] [4] 1. - Fedora Media Writer doesn´t turn into high contrast mode when toggling the high contrast. - Zoom seems blurry. - On the screen keyboard, every time I click on a word suggestion, the word gets dele ted. Every time I click enter, also the word gets deleted. When I disabled the screen keyboard, all input fields remain broken (they were just fine before).
2. Small freeze when changing users on the lock screen.
3. After suspending it (through the user menu) and going back to my user, all applications disappeared from the menu. When searching for an application, no app is shown also. When switching between users , the screen freezes.
4. Epiphany crashed when watching previews on YouTube (a single tab open). Also, music players are stacking on the notification tab even when I had already closed the video, and I can seen to find a way to delete them. Cannot add tabs to my favorites with the right click.
mmmarkkk Gnome Boxes on HP Elitebook 840 G8
modehnal Local VM from ISO [1] 1. Seems like no rpm can be installed, Flatpaks look ok.
modehnal Local VM instlaled from ISO [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] 1. Screen Keyboard has different layout for Terminal that changes upon click (losing some buttons). I am not seeing this layout in Shell Overview or in Text Editor. Slow Keys do not trigger notification , I made no changes to the system from the installation.
2. When System Menu is opened and you move cursor down to the screen over the opened panel, so that the Menu stays open -> when moving cursor over Application or Places they do not react to clicks or mou se hovers. This cannot be reproduced from other menus - Clock, Places, Applications
3. Everything seems functional but I noticed a weird interaction with Settings that I did not notice on other applications. When I have Settings open and I attempt to open another Settings via Applicatio ns menu, the cursor changes to loading wheel for 10+ seconds.
4. When entering a wrong password the Gear button for session type/desktop change disappears. And after that when clicking on the Back button the button reappears but I am still on the password instead o n User selection.
5. Lock Screen in GNOME Classic does not have outline for password entry, it blends to the background, but flashes white for a moment if I press Esc before the Screen with time shows.
6. Power Off and Restart work fine but Suspend makes me lose control of the machine and virt-manager I have to kill the qemu process. I get an error: "Error shutting down domain: Requested operation is n ot valid: domain is not running" Might very well be issue with virt-manager.
7. Login and switching users works fine but I see no Language option on login screen so even for languages set to users (CZ, FR) I need to enter password in US keyboard layout. Languages are loaded fine in users themselves. I also seem to unable to smoothly switch between logged users, it works for a time but stops working suddenly - might be the issue with virt-manager though.
8. There seems to be no debug option (gnome-music -d) as described in How to test. When starting via Terminal it gives an error: "libEGL warning: DRI2: failed to authenticate"
9. Youtube video will trigger multiple notification entries. Each of them can control the one video playing but only the top notification will be modified. The notifications cannot be removed unless the video is closed. Many times the Label of the notification controlling the video is not even the correct video but previous one or one I have not started at all.
10. Youtube jumping to the part of the video that was not yet buffered makes youtube stop and show loading wheel, sometimes clicking back as if to the buffered part makes it start playing but a few times video was no longer playable and I had to reload the page to make the video play again.
mpearson X1 Yoga G7
naraiank VMWare workstation 16 Player [1] [2] [3] [4] [5] [6] 1. Working
2. #2119057, For more info check: https://bugzilla.redhat.com/show_bug.cgi?id=2119057
3. #2119094, Progress bar is not showing up in gnome music. For more details: https://bugzilla.redhat.com/show_bug.cgi?id=2119094
4. Searching and showing music from "Music" Directory.
5. #2119087, for more info check: https://bugzilla.redhat.com/show_bug.cgi?id=2119087
6. #2117710, For more info, Check: https://bugzilla.redhat.com/show_bug.cgi?id=2117710
pnemade KVM [1] [2] 1. Able to add/remove package. Install new update. Got auto installed langpacks for newly set desktop language.
2. evince works
pratajo HP Victus notebook with AMD Ryzen 5 5600H and Radeon Graphics [1] [2] [3] [4] [5] 1. "A notification should tell you that slow keys were turned on, and offer you to turn it off or keep it" - no notification at all
2. "Winkey" + "L" do not lock user session
3. No language option on login screen to write characters not available on 'en' keyboard layout
4. 'gnome-music -d in debug mode' result in '-d option unknown' (google translator)
5. Cannot install apps because "they are not supported"
remyabel libvirt [1] [2] 1. Notification successfully popped up. GNOME Software shows applications that were updated with Restart & Update prompt. Restart & Update did successful offline upgrade. Notification that updates were i nstalled pops up, updated apps appear in the list.
2. Installing RPM/Flatpak and uninstalling RPM/Flatpak seems to work fine. Launching Flatpak after installation seems to work fine, but not RPM. Application installed via dnf from command line does not s eem to show up in Installed list. Application installed as RPM does not launch when clicking Open from GNOME Software after installation. The install button disappears until another option is selected. When installing via Flatpak, a notification about bad signing key appears
tpelka local VM
user bare metal, Gigabyte Technology Co., Ltd. GA-880GM-UD2H, Fedora Linux 37 (Workstation Edition Prerelease), 64-bit
vbudikov [1] 1. When I lock the screen, I see the lock screen half a second, then the screen goes black, I have to hit the keyboard to see actual time and date again.
vbudikov Lenovo T470S [1] [2] [3] [4] 1. Screen reader does not read correctly. It skipped parts, e.g. when I change toggle button from on to off it does not read this or when I open Typing Assist dialog, it does not read everything.
2. When I lock the screen, I see the lock screen half a second, then the screen goes black, I have to hit the keyboard to see actual time and date again.
3. No language option on login screen.
4. Debug mode does not work for me.
vhumpa VM [1] 1. Enabling Larged text abrt'ed (but large text worked). Poor performance of Zoom - but could be realted to using VM.
vhumpa qemu-kvm qxl/spice [1] 1. Didn't find the 'Expandable Folders in List View' option. Not sure if this feature is removed on purpose. Do have it with nautilus-41

Gnome Shell

Username Profile Activities Extensions Dash Extensions gnome org Extensions install Extensions remove Extensions tweak tool Overview Search Workspaces Comments
Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result
andilinux GNOME BOXES
bittin Virtualbox [1] 1. gnome-extensions-app is used nowadays instead of gnome-tweaks for extensions
bmilar Dell Precision 3551 [1] [2] 1. gnome-extensions-app shows only some of installed extensions.
2. Gnome extensions listed in Software could not be installed ("Unable to find ...")
couchfox Dell Inspiron 7577 [1] 1. (Test case needs an update for gnome-extensions-app) No extensions can be installed via gnome-software at this time. I installed some extensions via DNF, however, those extensions then do not appear i n gnome-extensions-app; only the built-in extensions are listed. The extensions themselves generally do not function -- I assume it is a bit early for third-party extensions.
domcox bare metal
freddyw VIrtualBox [1] [2] [3] 1. installed the flatpak version from flathub. Needed to logout/login to make it work. The flatpak 'com.mattjakeman.ExtensionManager' seems to do a better job however.
2. The browser extension is only available for firefox but after installing: Your native host connector do not support following APIs: v6.
3. N/A. No longer used for managing extensions.
heliosstyx bare metal [1] [2] [3] [4] [5] 1. no extensions on gnome.org extensions for Gnome 43 Beta. Some extensions from the Fedora RPM does not work, they should be removed or updated.
2. for current version no extensions.
3. if some exists!
4. it makes no sense, because it's outdated.
5. works fine.
hricky Intel® Core™ i7-4790 CPU, 32 GB RAM, Bare Metal [1] [2] [3] [4] 1. Extension application can manipulate installed extensions. Background Logo extension is incompatible with the current GNOME version. Gnome extensions listed in Software could not be installed ("Unable to find ..."). I can't manage to install from extensions.gnome.org.
2. Going back to the main page and browsing through available extensions I didn't see any previously installed (not using web interface) extension.
3. Some extensions from the repos work, other does not. Gnome extensions listed in Software could not be installed ("Unable to find ...").
4. No longer in use for managing extensions.
mairacanal F37 Workstation on Intel i5-4460 CPU with Radeon RX5700 XT [1] 1. Installed on Software through Flatpak, but I cannot open the app.
modehnal Local VM from ISO [1] 1. While Extension application can manipulate with extensions just fine. Searching for gnome-shell-extensions in Software will find some but upon clicking will show error that it was unable to find them. dnf will show some but does not enable them automatically after installation from what I can tell. I am unable to install from extensions.gnome.org
mpearson X1 Yoga G7
pnemade KVM
remyabel

Gnome Online Accounts

Username Profile Add Google Add IMAP and SMTP Add Kerberos Add ownCloud Comments
Enter result Enter result Enter result Enter result
andilinux GNOME BOXES [1] [2] 1. nextcloud worked
2. used nextcloud and worked
couchfox Dell Inspiron 7577 [1] 1. Tested with Fastmail service, via IMAP/SMTP.
domcox bare metal [1] [2] 1. Tested on my Nextcloud server
2. Settings freezes while connecting to the server. Tested with both the FQDN and IP address. Same settings as my regular laptop (f36).
freddyw VIrtualBox
heliosstyx bare metal [1] 1. Microsoft services.
hricky Intel® Core™ i7-4790 CPU, 32 GB RAM, Bare Metal
mairacanal F37 Workstation on Intel i5-4460 CPU with Radeon RX5700 XT
modehnal Local VM from ISO

Disk Management

Username Profile Basic Modify Comments
Enter result Enter result
andilinux GNOME BOXES
bittin Virtualbox
bittin Virtualbox
bmilar Dell Precision 3551 [1] 1. For disks with >30 partitions, some of them do not fit in the scheme (horizontal view) and thus (having no scroller) they are hidden for the user.
couchfox Dell Inspiron 7577
domcox bare metal
freddyw VIrtualBox
geraldosimiao x86_64 KVM virt-manager UEFI [1] 1. Live-x86_64-37-20220815.n.0.iso
heliosstyx bare metal [1] [2] 1. btrfs!
2. btrfs!
hricky Intel® Core™ i7-4790 CPU, 32 GB RAM, Bare Metal
mairacanal F37 Workstation on Intel i5-4460 CPU with Radeon RX5700 XT
mmmarkkk Gnome Boxes on HP Elitebook 840 G8
modehnal Local VM from ISO
pnemade KVM

Exploratory Testing

Username Profile Exploratory Testing Comments
Enter result
aday Boxes [1] 1. #2119089, Device security panel temporarily visible in a VM: https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2016 Night light unavailable info bar doesn't look very good: https://gitlab.gnome.org/ GNOME/gnome-control-center/-/issues/2020 Software explore page is missing content, has an odd layout: https://bugzilla.redhat.com/show_bug.cgi?id=2119089
alciregi Intel NUC 7i5BNH [1] 1. Settings -> Power -> Set Screen blank to something The value is still 5 minutes
bittin Virtualbox [1] 1. Shut down button gone from the new Quick menu after logging in as two users
bmilar Dell Precision 3551 [1] [2] 1. See Gnome Gitlab - https://gitlab.gnome.org/GNOME/nautilus/-/issues/2441
2. #2441, nautilus crashes while opening USB disk unmounted by gnome-disks.
couchfox Dell Inspiron 7577 (bare metal) [1] 1. #5779, System Status menu - VPN Button: VPN connection can be toggled ON but not OFF, however, this appears to be addressed in https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/5779
domcox bare metal [1] [2] 1. After having setup a Wireguard connexion, it shows up in the new quick menu, and you can activate the connection. Once connected, you cannot deactivate it anymore. You have to rely on nmcli con down w g0.
2. Happenning randomly: all applications disappear from overview and Favourites (Pin) panel, Halt and Reboot options are gone from the new Quick menu. Hitting the Halt button in the logout window launche d by Ctrl+Alt+Del does nothing.
heliosstyx bare metal [1] 1. on this early stage of Fedora 37 Workstation it works very well. Thank you to all contributors for this excellent work.
mairacanal F37 Workstation on Intel i5-4460 CPU with Radeon RX5700 XT [1] [2] 1. Shut down button disappeared from the new user menu after logging in as two users (it disappeared on both users)
2. Gnome Videos don´t open H.624 videos. When opened from Nautilus, Files doesn´t show any warning, just a blank screen. When opening an H.624 video from the Gnome Videos app, it shows a warning. This sh ould be the expected behavior from Nautilus also.
modehnal Local VM instlaled from ISO [1] [2] [3] [4] 1. Settings got stuck for a few seconds when I clicked on Appearance, some error messages and stack traces appeared in journal that indicate that the object was already destroyed
2. I was unable to start Extensions app from Overview but I was able to from Software. Upon closer look there are both versions installed, rpm and flatpak, but Overview showed rpm which I am unable to op en even from Software that provides me with Open button.
3. Sometimes in System menu there is only Log Out option button. Everything else disappears, I have not yet found a specific reproducer.
4. Happened twice already in span of a 5 minutes, when changing between GNOME Classic to GNOME, all applications disappear from overview and Favourites (Pin) panel.
mpearson X1 Yoga G7 [1] 1. Don't know if it's a bug as I suspect it's working as designed and I just don't like the design: When disabling Bluetooth (for example) from the systray it sits there and stays lit for quite a while ( enough that I thought it hasn't worked), and then the box disappears. To enable BT again I have to go into settings to turn it on. I assume the aim is to keep that systray as minimal as possible, but I found it a bit confusing. Having the audio select from there is awesome though.
Wiki Metadata